rss
twitter
    Envie de me voir sur Twitter ? Follow me !
BlogBang

Personnaliser la barre des tâches du eeePC

Comme je l'ai dit dans un précédent article, icewm est le gestionnaire de fenêtres par défaut du eeePC. Son intérêt évident est sa légèreté mais heureusement pour nous, sa personnalisation est d'autant plus intéressante.

J'aborderai progressivement quelques exemples (les différents fichiers peuvent être un peu complexes pour les novices) afin de savoir utiliser correctement le potentiel d'icewm.

Ce qui peut gêner (et qui m'a gêné moi), ce sont les icônes présents à côté du systray (les icônes de notification présents dans la barre des tâches). On y retrouve :
  • un carré vert qui représente le gestionnaire de tâches accessible en appuyant sur "Fn+F6" ;
  • un smiley qui sert à pas grand chose. Je n'aime pas trop les manuels d'utilisation "interne", le bon manuel papier sert amplement ^^ ;
  • un panneau stop qui sert à stopper la session et autres, accessible en appuyant sur le bouton Power du eeePC.
Comme vous le voyez, ces trois icônes ne sont pas totalement indispensables. On peut accéder aux différents menus facilement par d'autres raccourcis. ;)
J'ai donc décidé de les supprimer. Si vous avez suivi les anciens articles, vous devriez avoir un dossier caché "icewm" dans "/home/user/". Si ce n'est pas le cas, appelez un terminal avec "Ctrl+Alt+T" et rentrez les commandes suivantes :

mkdir /home/user/.icewm
cp /etc/X11/icewm/* /home/user/.icewm/


Ensuite, nous alllons modifier le fichier responsable de cette partie de la barre des tâches.

kwrite .icewm/toolbar2

Le fichier va s'ouvrir, il suffit de commenter les lignes qui nous intéressent. Pour commenter une ligne, un simple "#" devant la ligne et elle deviendra "silencieuse". Mon fichier ressemble à ça :

#prog "SOS" taskmanager ksysguard --showprocesses
#prog "Eee PC Tips" eeepctips firefox file:///opt/xandros/share/eeetips/index.html
#prog "Shutdown" shutdown /opt/xandros/bin/shutdown_dialog shutdown


A vous de voir ce que vous voulez garder ou enlever, perso, comme je l'ai dit, je n'ai pas besoin de ces icônes. ;)
Pour voir les changements, redémarrez le serveur graphique avec "Ctrl+Alt+BackSpace" ou alors redémarrez le eeePC. Les icônes devraient ne plus être là. ;)

Tcho, Hamtaro.

19 commentaires:

lowett a dit…

Je passe ici pour te remercier de ton commentaire sur mon blog. Tomber sur ce blog me redonne du courage à utiliser Xandros.
J'ai encore du chemin à faire concernant le wifi ...
Si tu veux m'aider, je bloque pour appliquer la procédure décrite à cette adresse: http://www.uclouvain.be/80783.html
Il y a aussi une procédure pour Network Manager, sous Ubuntu ici: http://www.uclouvain.be/167637.html
Elle semble beaucoup plus facile, cependant je ne sais pas si c'est possible d'installer Network Manager sur Xandros... Et si c'est possible, je ne sais absolument pas comment faire ...

Voilà et si jamais tu avais eu vent d'un tutoriel pour résoudre les connexions sur wifi sécurisé, je suis preneuse.
Notre problème, c'est que la connexion sur le wifi reste bloquée sur "en cours".
Nous avons paramétré le modem via une adresse ip tapée dans un navigateur web, et y avons rajouté l'adresse mac de mon eeePC. (ath0 qqch je crois... enfin celle qui concerne le wifi donc on sait que c'est la bonne)
Du coup, je vois dans "réseau sans fil" le réseau de mon copain.
Ensuite, il me demande une clé wep. Nous sommes retournés voir dans les paramètres du modem et avons trouvé 4 clés wep. Nous avons testé chacune de ces clés, en changeant bien son index dans "index de la clef". Mais rien n'y fait, cela reste bloqué sur "en cours".
J'ai lu à un endroit qu'il fallait que le SSID n'aie pas d'espace. Or, il a bien un espace (pour exemple on va dire Lowett WiFi). Si je supprime l'espace dans le nom de réseau (en allant dans Internet puis Réseau puis le réseau sans fil en question), cela ne change rien... On est totalement bloqués sur ce coup là aussi.
Et nous avons chercher sur le web différentes solutions et tout ce que nous avons appris, c'est que nous ne sommes pas les seuls à avoir ce problème...

Hamtaro a dit…

Mon réseau Free à la maison est lui même sécurisé et je n'ai pas de problème...
Bon, c'est juste une clef WEP, le réseau de ta fac semble plus hard...
Et avec eux ? Avec le service informatique, tu as été les voir ?

TCho, Hamtaro.

lowett a dit…

Non je n'ai pas encore pu aller les voir. Ils ont de nuls horaires de permanence :(
Mais demain je vois des gens qui pourront peut-être m'aider, et s'ils savent pas, j'irai voir le service info de l'université en fin de semaine.

Tu as du faire aucune manip pour ton réseau free ?
Il est visible par tous ou bien il faut entrer son adresse mac dans les paramètres pour pouvoir le voir puis s'y connecter et entrer la clé wep ?

Hamtaro a dit…

Mon réseau est visible par tous, avec un accès avec une clef WEP.
Je suis vraiment désolé de ne pas pouvoir trop t'aider là dessus...

Tcho, Hamtaro.

lowett a dit…

Pas grave, merci quand même ...
Est-ce que tu sais si le programme Network Manager d'Ubuntu est installable sur le Xandros de l'eeePC?
Si oui, tu sais me dire comment il faut faire ?
Si non, il n'y aurait pas un équivalent de ce programme pour Xandros ?

Hamtaro a dit…

J'ai essayé en activant des dépôts Debian mais l'installation recquiert des dépendances un peu périeuses...
Je n'ai pas réussi à l'installer mai ça doit être faisable. Pour ce qui est de l'équivalence sous Xandros, je pense que c'est ce qui est installé par défaut. :)

Tcho, Hamtaro.

cricx a dit…

j'avais le même problème de wifi qui ne fonctionnait pas (état : en cours). En fait, la communication radio se fait bien, mais l'interface n'arrive pas à se configurer (pas d'offre dhcp). Ceci est dû en général à une erreur de clé (wep ou wpa).

j'ai galéré un moment pour trouver la solution, sans trouver où ça se passait.

J'ai fini par restaurer le système (F9 au démarrage), reconfiguré la connexion et c'est maintenant OK.

Pour info, ceci est arrivé après une connexion filaire (qui était configuré en démarrage automatique). J'ai lu quelque part que ça pouvait provenir de ça et qu'il valait mieux configurer les interfaces réseau (filaire et sans fil) en mode manuel.

C'est ce que j'ai fait et depuis, plus de pb.

lowett a dit…

Merci CRICX, j'essaierai quand j'aurai l'occasion... Restaurer le système = effacer toutes les données?

Sinon un truc que j'ai remarqué c'est que l'adresse mac wifi de mon eee pc a changé... J'ai fais tellement de manipulations que je ne sais pas ce qui a pu faire ça. J'ai pourtant chaque fois suivi des tutoriels du forum de blogeee ou eeeuser...

Maintenant mon adresse mac est trop longue !
C'est xx-xx-xx-xx-xx-xx-xx-xx-00-00-00-00-00-00-00-00
Les x correspondent à des chiffres et lettres normaux, mais après j'ai réellement toute cette série de zéros.
Comment je peux la "remettre" comme avant? En restaurant le système aussi ?

Merci d'avance

Hamtaro a dit…

Oula...
Toi, on peut dire que le wifi t'en fait voir de toutes les couleurs ^^
Je ne sais pas ce que tu as fait comme manip avant et quels tutos tu as faits. A priori, il suffirait de les reprendre "à l'envers". Fais voir un peu ce que tu as fait.

TCho, Hamtaro.

lowett a dit…

Houla Hamtaro ça va être compliqué de te dire tout ce que j'ai fais... Il y avait trop de trucs.
Mais je penche plutôt pour une restauration... Il suffit de faire F9 au démarrage? Cela résoudra ce problème d'adresse mac?

cricx a dit…

@lowett : pour ton problème de wifi :
Je pense qu'il vaut miseux que tu en parles sur le forum de pierre (en fait tu en as parlé hier, mais sans donner déléments pour qu'on t'aide pour pouvoir te connecter sur le réseau de yannick).

Ce que j'ai constaté, en voulant paramétrer l'eeepc du boulot, c'est que ça ne fonctionnait pas (en wpa). En regardant d'un peu plus près, je me suis rendu compte que la clé (stockée en clai dans /etc/network/interfaces) était récupérée par un script qui était fortement perturbé par certains caractères (notamment les ", ', `, et d'autres du même genre).

Je pense qu'il te faut vérifier que la clé ne contient que des caractères normaux.

lowett a dit…

Salut cricx!
Merci pour toutes ces explications. Mais comme expliqué sur mon blog, je n'ai eu qu'à créer la connexion moi-même... Ça marche, maintenant :)

Je pense que j'ai eu beaucoup de mal au début car j'avais fait plein de manip pour le wifi de mon université... Mais depuis que j'ai réinitialisé Xandros, tout va beaucoup mieux =)

cricx a dit…

@lowett :
OK (c'était bien ce que je pensais).
Je ne lis pas ton blog [pas de mon âge ;)] donc je ne savais pas que ton pb étais résolu.

LaGazelleN a dit…

Salut Hamtaro,

J'ai cherché mais je n'ai pas trouvé :

Comment activer sous "bureau entier" les icones qu'on trouve dans la barre des taches "easy" qui permettent de visualiser l'activation ou non du ver num et des majuscules ? ca me serait vachement utile, surtout pour les mots de passe entre autre.

merci

cricx a dit…

dans /usr/bin/startfull.sh, rajouter une ligne avec :
/usr/bin/keyboardstatus

(c'est cette commande qui lance l'icône que tu veux).

Je n'ai pas testé (je n'utilise pas le mode full).

Essaye éventuellement avant de lancer cette commande dans une console, pour voir si l'icône apparaît.

teddy a dit…

lorsque l'on suit cette manip : "kwrite .icewn/toolbar2" est il normal de tomber sur un éditeur de texte où il n'y a rien d'inscrit !
au fait tres bon blog, merci !

Hamtaro a dit…

@ teddy : attention à l'orthographe des commandes. c'est "icewm" et non "icewn".;)

Tcho,Hamtaro.

teddy a dit…

merci Hamtaro, je m'étais effectivement trompé entre le m et le n. erreur stupide de ma part!
En revanche je ne trouve toujours pas la ligne pour changer le theme, mais cette fois ci j'ai fait attention a l'othgraphe ... du moins je crois! Je vais revérifier...

Zitoune a dit…

marche plus avec xandros 1.6 ?

 
BlogBang